找回密码
 注册

通达信公式——缠论MACD背驰副图附图指标

逍遥子 2020-8-9 06:01

东方财经网
公式名称: MACD背驰

副图}


通达信公式——缠论MACD背驰副图附图指标


DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA),COLORSTICK,LINETHICK2;

VAR1:=CROSS(DIFF,DEA) AND DIFF<(-0.1);

STICKLINE(VAR1,0,0.08,6,0),COLORYELLOW;

DRAWTEXT(VAR1,0.16,44),COLORWHITE;

VAR8:=SUM(MACD值,0);

VAR9:=IF(MAX(VAR8,REF(VAR8,2))<REF(VAR8,1) OR MIN(VAR8,REF(VAR8,2))>REF(VAR8,1),1,0);

VAR10:=BARSLAST(VAR9)+1;

VAR11:=VAR8-REF(VAR8,VAR10);

VAR12:=IF(MACD值>0,HHV(ABS(MACD值),VAR10),LLV(MACD值,VAR10));

VAR13:=MACD值/20;

面积:VAR11,NODRAW;

DRAWNUMBER(REF(VAR13,1)>0 AND VAR13<=0,REF(VAR12,1),REF(面积,1)),COLORMAGENTA;

DRAWNUMBER(REF(VAR13,1)<0 AND VAR13>=0,REF(VAR12,1),REF(ABS(面积),1)),COLORGREEN;

DRAWNUMBER(ISLASTBAR AND VAR13<0,REF(VAR12,1),ABS(面积)),COLORMAGENTA;

DRAWNUMBER(ISLASTBAR AND VAR13>0,REF(VAR12,1),面积),COLORGREEN;

更多《趋势停顿与转折+玩转MACD》、《沧桑战神之均线战法研究》、《擒住大牛:一本书搞懂分时图战法:狙击黑马》学习资料!快速解决你的选股、买卖点、跟庄、看盘问题!本人承诺,本人不卖软件,不卖指标,不做分层,一切分享,均不收取任何费用,若有人打着本人名号,收取费用,请不要上当受骗!各位粉丝朋友们的支持是本人最大的动力!本人独创的技术和指标,不会使用或者有需要绝密组合指标——【“黄金坑主图+黄金坑选股器”】(全套源码)的朋友。看下图,找我免费领取!《看下方↓↓↓↓↓↓↓↓↓↓↓》


通达信公式——缠论MACD背驰副图附图指标

文章点评